import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=.*TM_TASK)(?=.*TM_CHECKLIST).*";
final String string = "TM_TASK TM_CHECKLIST is present\n"
+ "is only TM_TASK is present don't match\n"
+ "is only TM_CHECKLIST is present don't match";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}