import re
regex = re.compile(r"(?=.*TM_TASK)(?=.*TM_CHECKLIST).*", flags=re.MULTILINE)
test_str = ("TM_TASK TM_CHECKLIST is present\n"
"is only TM_TASK is present don't match\n"
"is only TM_CHECKLIST is present don't match")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")