re = /(?=.*TM_TASK)(?=.*TM_CHECKLIST).*/m
str = 'TM_TASK TM_CHECKLIST is present
is only TM_TASK is present don\'t match
is only TM_CHECKLIST is present don\'t match'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end