using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=.*TM_TASK)(?=.*TM_CHECKLIST).*";
string input = @"TM_TASK TM_CHECKLIST is present
is only TM_TASK is present don't match
is only TM_CHECKLIST is present don't match";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}