$re = '/(?=.*TM_TASK)(?=.*TM_CHECKLIST).*/m';
$str = 'TM_TASK TM_CHECKLIST is present
is only TM_TASK is present don\'t match
is only TM_CHECKLIST is present don\'t match';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);