#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^foo\.bar\.lib(?:\..*)?(?<!unsafe)\.\w+$"
Local $sString = "foo.bar.lib.Main" & @CRLF & _
"foo.bar.lib.impl.Main" & @CRLF & _
"foo.bar.libxxx.Main" & @CRLF & _
"foo.bar.libxxx.impl.Main" & @CRLF & _
"" & @CRLF & _
"foo.bar.lib.unsafe.Unsafe" & @CRLF & _
"foo.bar.lib.unsafe.Unsafe" & @CRLF & _
"foo.bar.libxxx.unsafe.Unsafe" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"foo.bar.lib.util.Main" & @CRLF & _
"foo.bar.lib.impl.util.Main" & @CRLF & _
"foo.bar.libxxx.util.Main" & @CRLF & _
"foo.bar.libxxx.impl.util.Main" & @CRLF & _
"" & @CRLF & _
"foo.bar.lib.util.unsafe.Unsafe" & @CRLF & _
"foo.bar.lib.util.unsafe.Unsafe" & @CRLF & _
"foo.bar.libxxx.util.unsafe.Unsafe"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")