import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^foo\\.bar\\.lib(?:\\..*)?(?<!unsafe)\\.\\w+$";
final String string = "foo.bar.lib.Main\n"
+ "foo.bar.lib.impl.Main\n"
+ "foo.bar.libxxx.Main\n"
+ "foo.bar.libxxx.impl.Main\n\n"
+ "foo.bar.lib.unsafe.Unsafe\n"
+ "foo.bar.lib.unsafe.Unsafe\n"
+ "foo.bar.libxxx.unsafe.Unsafe\n\n\n"
+ "foo.bar.lib.util.Main\n"
+ "foo.bar.lib.impl.util.Main\n"
+ "foo.bar.libxxx.util.Main\n"
+ "foo.bar.libxxx.impl.util.Main\n\n"
+ "foo.bar.lib.util.unsafe.Unsafe\n"
+ "foo.bar.lib.util.unsafe.Unsafe\n"
+ "foo.bar.libxxx.util.unsafe.Unsafe";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}