use strict;
my $str = 'foo.bar.lib.Main
foo.bar.lib.impl.Main
foo.bar.libxxx.Main
foo.bar.libxxx.impl.Main
foo.bar.lib.unsafe.Unsafe
foo.bar.lib.unsafe.Unsafe
foo.bar.libxxx.unsafe.Unsafe
foo.bar.lib.util.Main
foo.bar.lib.impl.util.Main
foo.bar.libxxx.util.Main
foo.bar.libxxx.impl.util.Main
foo.bar.lib.util.unsafe.Unsafe
foo.bar.lib.util.unsafe.Unsafe
foo.bar.libxxx.util.unsafe.Unsafe';
my $regex = qr/^foo\.bar\.lib(?:\..*)?(?<!unsafe)\.\w+$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}