import re
regex = re.compile(r"^foo\.bar\.lib(?:\..*)?(?<!unsafe)\.\w+$", flags=re.MULTILINE)
test_str = ("foo.bar.lib.Main\n"
"foo.bar.lib.impl.Main\n"
"foo.bar.libxxx.Main\n"
"foo.bar.libxxx.impl.Main\n\n"
"foo.bar.lib.unsafe.Unsafe\n"
"foo.bar.lib.unsafe.Unsafe\n"
"foo.bar.libxxx.unsafe.Unsafe\n\n\n"
"foo.bar.lib.util.Main\n"
"foo.bar.lib.impl.util.Main\n"
"foo.bar.libxxx.util.Main\n"
"foo.bar.libxxx.impl.util.Main\n\n"
"foo.bar.lib.util.unsafe.Unsafe\n"
"foo.bar.lib.util.unsafe.Unsafe\n"
"foo.bar.libxxx.util.unsafe.Unsafe")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")