$re = '/^foo\.bar\.lib(?:\..*)?(?<!unsafe)\.\w+$/m';
$str = 'foo.bar.lib.Main
foo.bar.lib.impl.Main
foo.bar.libxxx.Main
foo.bar.libxxx.impl.Main
foo.bar.lib.unsafe.Unsafe
foo.bar.lib.unsafe.Unsafe
foo.bar.libxxx.unsafe.Unsafe
foo.bar.lib.util.Main
foo.bar.lib.impl.util.Main
foo.bar.libxxx.util.Main
foo.bar.libxxx.impl.util.Main
foo.bar.lib.util.unsafe.Unsafe
foo.bar.lib.util.unsafe.Unsafe
foo.bar.libxxx.util.unsafe.Unsafe';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);