#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(.*) ([0-9]{5}) (.*)"
Local $sString = "19 Rue Clément Ader 91220 Brétigny-sur-Orge" & @CRLF & _
"35bis Rue des Ecoles 91700 Sainte-Geneviève-des-Bois" & @CRLF & _
"7 Avenue Gilbert Fergant 91220 Le Plessis-Pâté"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")