// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(.*) ([0-9]{5}) (.*)").unwrap();
let string = "19 Rue Clément Ader 91220 Brétigny-sur-Orge
35bis Rue des Ecoles 91700 Sainte-Geneviève-des-Bois
7 Avenue Gilbert Fergant 91220 Le Plessis-Pâté";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}