$re = '/(.*) ([0-9]{5}) (.*)/m';
$str = '19 Rue Clément Ader 91220 Brétigny-sur-Orge
35bis Rue des Ecoles 91700 Sainte-Geneviève-des-Bois
7 Avenue Gilbert Fergant 91220 Le Plessis-Pâté';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);