using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*) ([0-9]{5}) (.*)";
string input = @"19 Rue Clément Ader 91220 Brétigny-sur-Orge
35bis Rue des Ecoles 91700 Sainte-Geneviève-des-Bois
7 Avenue Gilbert Fergant 91220 Le Plessis-Pâté";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}