package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(.*) ([0-9]{5}) (.*)`)
var str = `19 Rue Clément Ader 91220 Brétigny-sur-Orge
35bis Rue des Ecoles 91700 Sainte-Geneviève-des-Bois
7 Avenue Gilbert Fergant 91220 Le Plessis-Pâté`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}