const regex = /(.*) ([0-9]{5}) (.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.*) ([0-9]{5}) (.*)', 'gm')
const str = `19 Rue Clément Ader 91220 Brétigny-sur-Orge
35bis Rue des Ecoles 91700 Sainte-Geneviève-des-Bois
7 Avenue Gilbert Fergant 91220 Le Plessis-Pâté`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}