#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b(?![A-Z]+\b)[a-zA-Z0-9_{}]*\b"
Local $sString = "VarWithCapitals" & @CRLF & _
"variable" & @CRLF & _
"var_with_snake_case" & @CRLF & _
"var_with_{curly}_braces" & @CRLF & _
"Var_with_The_{kitchen123}_Sink" & @CRLF & _
"CMD" & @CRLF & _
"DO" & @CRLF & _
"WHILE" & @CRLF & _
"ENDWHILE" & @CRLF & _
"FOR"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")