const regex = /\b(?![A-Z]+\b)[a-zA-Z0-9_{}]*\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?![A-Z]+\\b)[a-zA-Z0-9_{}]*\\b', 'gm')
const str = `VarWithCapitals
variable
var_with_snake_case
var_with_{curly}_braces
Var_with_The_{kitchen123}_Sink
CMD
DO
WHILE
ENDWHILE
FOR`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}