import re
regex = re.compile(r"\b(?![A-Z]+\b)[a-zA-Z0-9_{}]*\b", flags=re.MULTILINE)
test_str = ("VarWithCapitals\n"
"variable\n"
"var_with_snake_case\n"
"var_with_{curly}_braces\n"
"Var_with_The_{kitchen123}_Sink\n"
"CMD\n"
"DO\n"
"WHILE\n"
"ENDWHILE\n"
"FOR")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")