import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?![A-Z]+\\b)[a-zA-Z0-9_\\{\\}]*\\b";
final String string = "VarWithCapitals\n"
+ "variable\n"
+ "var_with_snake_case\n"
+ "var_with_{curly}_braces\n"
+ "Var_with_The_{kitchen123}_Sink\n"
+ "CMD\n"
+ "DO\n"
+ "WHILE\n"
+ "ENDWHILE\n"
+ "FOR";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}