#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(WORD1)\h+.{0,5000}(WORD2).{0,5000}(WORD3)|(WORD1)\h+.{0,5000}(WORD2).{0,5000}(WORD3)|(WORD1)\h+.{0,5000}(WORD2).{0,5000}(WORD3)|(WORD1)\h+.{0,5000}(WORD2).{0,5000}(WORD3)|(WORD1)\h+.{0,5000}(WORD2).{0,5000}(WORD3)|(WORD1)\h+.{0,5000}(WORD2).{0,5000}(WORD3)"
Local $sString = "WORD1 asdfk WORD2 asdfklj WORD3"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")