// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(WORD1)\h+.{0,5000}(WORD2).{0,5000}(WORD3)|(WORD1)\h+.{0,5000}(WORD2).{0,5000}(WORD3)|(WORD1)\h+.{0,5000}(WORD2).{0,5000}(WORD3)|(WORD1)\h+.{0,5000}(WORD2).{0,5000}(WORD3)|(WORD1)\h+.{0,5000}(WORD2).{0,5000}(WORD3)|(WORD1)\h+.{0,5000}(WORD2).{0,5000}(WORD3)").unwrap();
let string = "WORD1 asdfk WORD2 asdfklj WORD3";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}