const regex = /(WORD1)\h+.{0,5000}(WORD2).{0,5000}(WORD3)|(WORD1)\h+.{0,5000}(WORD2).{0,5000}(WORD3)|(WORD1)\h+.{0,5000}(WORD2).{0,5000}(WORD3)|(WORD1)\h+.{0,5000}(WORD2).{0,5000}(WORD3)|(WORD1)\h+.{0,5000}(WORD2).{0,5000}(WORD3)|(WORD1)\h+.{0,5000}(WORD2).{0,5000}(WORD3)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(WORD1)\\h+.{0,5000}(WORD2).{0,5000}(WORD3)|(WORD1)\\h+.{0,5000}(WORD2).{0,5000}(WORD3)|(WORD1)\\h+.{0,5000}(WORD2).{0,5000}(WORD3)|(WORD1)\\h+.{0,5000}(WORD2).{0,5000}(WORD3)|(WORD1)\\h+.{0,5000}(WORD2).{0,5000}(WORD3)|(WORD1)\\h+.{0,5000}(WORD2).{0,5000}(WORD3)', 'gm')
const str = `WORD1 asdfk WORD2 asdfklj WORD3`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}