import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(WORD1)\\h+.{0,5000}(WORD2).{0,5000}(WORD3)|(WORD1)\\h+.{0,5000}(WORD2).{0,5000}(WORD3)|(WORD1)\\h+.{0,5000}(WORD2).{0,5000}(WORD3)|(WORD1)\\h+.{0,5000}(WORD2).{0,5000}(WORD3)|(WORD1)\\h+.{0,5000}(WORD2).{0,5000}(WORD3)|(WORD1)\\h+.{0,5000}(WORD2).{0,5000}(WORD3)";
final String string = "WORD1 asdfk WORD2 asdfklj WORD3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}