using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(WORD1)\h+.{0,5000}(WORD2).{0,5000}(WORD3)|(WORD1)\h+.{0,5000}(WORD2).{0,5000}(WORD3)|(WORD1)\h+.{0,5000}(WORD2).{0,5000}(WORD3)|(WORD1)\h+.{0,5000}(WORD2).{0,5000}(WORD3)|(WORD1)\h+.{0,5000}(WORD2).{0,5000}(WORD3)|(WORD1)\h+.{0,5000}(WORD2).{0,5000}(WORD3)";
string input = @"WORD1 asdfk WORD2 asdfklj WORD3";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}