re = /(WORD1)\h+.{0,5000}(WORD2).{0,5000}(WORD3)|(WORD1)\h+.{0,5000}(WORD2).{0,5000}(WORD3)|(WORD1)\h+.{0,5000}(WORD2).{0,5000}(WORD3)|(WORD1)\h+.{0,5000}(WORD2).{0,5000}(WORD3)|(WORD1)\h+.{0,5000}(WORD2).{0,5000}(WORD3)|(WORD1)\h+.{0,5000}(WORD2).{0,5000}(WORD3)/m
str = 'WORD1 asdfk WORD2 asdfklj WORD3'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end