package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d+(?:#?\d*|#[#*])$`)
var str = `我想要写匹配如下5种格式字符串的正则表达式:
1.数字
2.数字#
3.数字##
4.数字#*
5.数字#数字
12334#
12334##
12334#*
12334#12367
123123`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}