re = /^\d+(?:#?\d*|#[#*])$/m
str = '我想要写匹配如下5种格式字符串的正则表达式:
1.数字
2.数字#
3.数字##
4.数字#*
5.数字#数字
12334#
12334##
12334#*
12334#12367
123123'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end