const regex = /^\d+(?:#?\d*|#[#*])$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\d+(?:#?\\d*|#[#*])$', 'gm')
const str = `我想要写匹配如下5种格式字符串的正则表达式:
1.数字
2.数字#
3.数字##
4.数字#*
5.数字#数字
12334#
12334##
12334#*
12334#12367
123123`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}