$re = '/^\d+(?:#?\d*|#[#*])$/m';
$str = '我想要写匹配如下5种格式字符串的正则表达式:
1.数字
2.数字#
3.数字##
4.数字#*
5.数字#数字
12334#
12334##
12334#*
12334#12367
123123';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);