import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\d+(?:#?\\d*|#[#*])$";
final String string = "我想要写匹配如下5种格式字符串的正则表达式:\n"
+ "1.数字\n"
+ "2.数字#\n"
+ "3.数字##\n"
+ "4.数字#*\n"
+ "5.数字#数字\n\n"
+ "12334#\n"
+ "12334##\n"
+ "12334#*\n"
+ "12334#12367\n"
+ "123123";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}