#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[A-Z]+.*[A-Z].*\d+$"
Local $sString = "stroidom11" & @CRLF & _
"82sizFova28091982" & @CRLF & _
"Lyubyatin90977Bishop" & @CRLF & _
"LyubyatinBishop90977" & @CRLF & _
"SherefetdinovaMissalina193"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")