const regex = /^[A-Z]+.*[A-Z].*\d+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[A-Z]+.*[A-Z].*\\d+$', 'gm')
const str = `stroidom11
82sizFova28091982
Lyubyatin90977Bishop
LyubyatinBishop90977
SherefetdinovaMissalina193`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}