re = /^[A-Z]+.*[A-Z].*\d+$/m
str = 'stroidom11
82sizFova28091982
Lyubyatin90977Bishop
LyubyatinBishop90977
SherefetdinovaMissalina193'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end