using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[A-Z]+.*[A-Z].*\d+$";
string input = @"stroidom11
82sizFova28091982
Lyubyatin90977Bishop
LyubyatinBishop90977
SherefetdinovaMissalina193";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}