import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "輸入你的規則";
final String string = "# 題目名稱\n\n"
+ "# 題目說明區塊\n\n"
+ "#欲測試資料集\n\n\n"
+ "# 應配對結果(亮色區塊)";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}