// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"輸入你的規則").unwrap();
let string = "# 題目名稱
# 題目說明區塊
#欲測試資料集
# 應配對結果( 亮色區塊)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}