$re = '/輸入你的規則/';
$str = '# 題目名稱
# 題目說明區塊
#欲測試資料集
# 應配對結果(亮色區塊)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);