const regex = /輸入你的規則/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('輸入你的規則', 'g')
const str = `# 題目名稱
# 題目說明區塊
#欲測試資料集
# 應配對結果(亮色區塊)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}