# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"輸入你的規則"
test_str = ("# 題目名稱\n\n"
"# 題目說明區塊\n\n"
"#欲測試資料集\n\n\n"
"# 應配對結果(亮色區塊)")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.