$re = '/UserRoleCode:(?<UserRoleCode>\d+) UserRoleText:(?<UserRoleText>\w+)/ms';
$str = ' [1]UserRoleCode:1 UserRoleText:Admin
[2]UserRoleCode:2 UserRoleText:Developer';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);