#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\d?.?\d+[a-zA-Z]+"
Local $sString = "'Energy 1378kJ 328kcal 16.0%'" & @CRLF & _
"Salt 0g 0g 0.0%" & @CRLF & _
"Fat 6.4g 9.0%" & @CRLF & _
"Saturates 0g 0.0%" & @CRLF & _
"Sugars 5.7g 6.0%" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")