package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\d?.?\d+[a-zA-Z]+`)
var str = `'Energy 1378kJ 328kcal 16.0%'
Salt 0g 0g 0.0%
Fat 6.4g 9.0%
Saturates 0g 0.0%
Sugars 5.7g 6.0%
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}