re = /\d?.?\d+[a-zA-Z]+/m
str = '\'Energy 1378kJ 328kcal 16.0%\'
Salt 0g 0g 0.0%
Fat 6.4g 9.0%
Saturates 0g 0.0%
Sugars 5.7g 6.0%
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end