const regex = new RegExp('\\d?.?\\d+[a-zA-Z]+', 'gm')
const str = `'Energy 1378kJ 328kcal 16.0%'
Salt 0g 0g 0.0%
Fat 6.4g 9.0%
Saturates 0g 0.0%
Sugars 5.7g 6.0%
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}