import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d?.?\\d+[a-zA-Z]+";
final String string = "'Energy 1378kJ 328kcal 16.0%'\n"
+ "Salt 0g 0g 0.0%\n"
+ "Fat 6.4g 9.0%\n"
+ "Saturates 0g 0.0%\n"
+ "Sugars 5.7g 6.0%\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}