import re
regex = re.compile(r"\d?.?\d+[a-zA-Z]+", flags=re.MULTILINE)
test_str = ("'Energy 1378kJ 328kcal 16.0%'\n"
"Salt 0g 0g 0.0%\n"
"Fat 6.4g 9.0%\n"
"Saturates 0g 0.0%\n"
"Sugars 5.7g 6.0%\n\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")