using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=(?:(?!(?:post office|po)[ ,.-]?box).)*$)[\w ,.-]+$";
string input = @"this should match
and this too
Test Po Box - Should NOT be acceptable
Test Post Office Box - Should NOT be acceptable
Test Po,Box - Should NOT be acceptable
Test PO BOx - Should NOT be acceptable
Test-123po - Should be acceptable
Test-!@$% - Should NOT be acceptable
Test123@#$ PoBOX - Should NOT be acceptable.";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}