const regex = /^(?=(?:(?!(?:post office|po)[ ,.-]?box).)*$)[\w ,.-]+$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=(?:(?!(?:post office|po)[ ,.-]?box).)*$)[\\w ,.-]+$', 'gmi')
const str = `this should match
and this too
Test Po Box - Should NOT be acceptable
Test Post Office Box - Should NOT be acceptable
Test Po,Box - Should NOT be acceptable
Test PO BOx - Should NOT be acceptable
Test-123po - Should be acceptable
Test-!@\$% - Should NOT be acceptable
Test123@#\$ PoBOX - Should NOT be acceptable.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}