import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=(?:(?!(?:post office|po)[ ,.-]?box).)*$)[\\w ,.-]+$";
final String string = "this should match\n"
+ "and this too\n\n"
+ "Test Po Box - Should NOT be acceptable\n"
+ "Test Post Office Box - Should NOT be acceptable\n"
+ "Test Po,Box - Should NOT be acceptable\n"
+ "Test PO BOx - Should NOT be acceptable\n"
+ "Test-123po - Should be acceptable\n"
+ "Test-!@$% - Should NOT be acceptable\n"
+ "Test123@#$ PoBOX - Should NOT be acceptable.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}